Задать вопрос
20 июня, 18:29

Даго натурально число N. Написать программу для вычисления суммы 1*1+2*2+3*3 + ... + N*N.

+4
Ответы (2)
  1. 20 июня, 19:22
    0
    Программа на паскале:

    var n, i, s:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    s:=0;

    for i:=1 to n do s:=s+i*i;

    writeln ('s = ', s) ;

    end.

    Пример:

    n = 10

    s = 385
  2. 20 июня, 21:33
    0
    Python3:

    n = int (input ())

    print (n * (n + 1) * (2 * n + 1) / / 6)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даго натурально число N. Написать программу для вычисления суммы 1*1+2*2+3*3 + ... + N*N. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1. дано натурально четырехзначное число. определить цифры этого числа (K, L. M. N) и выяснить можно ли построить ромб со сторонами K, L. M. N. в паскале АВС. 2. дано натурально число N вычислить куб суммы этого числа
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)