Задать вопрос
30 апреля, 22:33

Набрать и выполнить программу замены во введенной с клавиатуры строке одного символа на другой. Оба символа также вводятся с клавиатуры.

+4
Ответы (2)
  1. 1 мая, 00:33
    0
    Var s, s1, s2:string;

    //вариант с несколькими символами в подстроках замены

    i, m:integer;

    begin;

    readln (s) ;

    readln (s1) ;

    readln (s2) ;

    while pos (s1, s) 0 do / / пока подстрока есть в строке выполнять

    begin;

    m:=pos (s1, s) ; / / сохраняем текущую позицию

    delete (s, pos (s1, s), length (s1)) ; / / удаляем ненужную подстроку

    Insert (s2, s, m) ; / / вставляем нужную подстроку на её место

    end;

    writeln (s) ;

    end.
  2. 1 мая, 01:42
    0
    Uses crt;

    var text, w, s: string; i: integer;

    Begin

    write ('Введите изначальный текст: ') ; readln (text) ;

    write ('Введи символ который хотите заменить: ') ; readln (w) ;

    write ('Чем заменить символ: ') ; readln (s) ;

    write ('Преобразованный текст: ') ;

    for i : = 1 to length (text) do

    if text[i] = w then write (s)

    else write (text[i]) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Набрать и выполнить программу замены во введенной с клавиатуры строке одного символа на другой. Оба символа также вводятся с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить все символы, начиная с середины.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)