Задать вопрос
13 ноября, 12:29

Составьте программу вычисления 1+2+4+8 + ... + 2 (в 10 степени)

+5
Ответы (1)
  1. 13 ноября, 13:12
    0
    Pascal abc;

    var a, b, sum:longint;

    begin

    b:=1;

    for a:=0 to 10 do begin

    sum:=sum+b;

    b:=b*2;

    end;

    writeln ('сумма чисел от 2^0 до 2^10 sum=', sum) ;

    end.

    С++;

    #include

    using namespace std;

    int main ()

    {

    int sum=0, b=1;

    for (int a=0; a<=10; a++)

    {

    sum=sum+b;

    b=b*2;

    }

    cout<<"сумма чисел от 2^0 до 2^10 sum = "<< sum;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления 1+2+4+8 + ... + 2 (в 10 степени) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
23 в 4 степени+21 в 8 степени = ответ в 10 степени 12 в 10 степени * 1010 в 2 степени = ответ в 3 степени (10101 в 2 степени + 212 в 3 степени) * 2 в 10 степени = ответ в 5 степени
Ответы (1)
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)