Задать вопрос
10 февраля, 22:47

Написать программу которая сформирует массив следующим образом:

A[1]=-1 A[2]=1 A[3]=-2 A[4]=2 A[5]=-3 A[6]=3 A[7]=-4

+1
Ответы (1)
  1. 11 февраля, 00:14
    0
    Var a:array[1 ... 7] of integer;

    ar, b, c:integer;

    begin;

    ar:=1;

    b:=1;

    for c:=1 to 7 do

    begin;

    ar:=-1*ar;

    a[c]:=ar;

    writeln (a[c]) ;

    if ar>0 then

    ar+=1;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая сформирует массив следующим образом: A[1]=-1 A[2]=1 A[3]=-2 A[4]=2 A[5]=-3 A[6]=3 A[7]=-4 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу которая сформирует целочисленный массив из n элементов и увеличит все элементы массива на значение максимального элемента.
Ответы (1)
Написать программу, которая: а) сформирует массив из 9-ти случайных целых чисел из промежутка (0; 5) б) выведет элементы массива в столбик с 4-го по 7-й элемент
Ответы (2)
Помогите! напишите программу которая сформирует три массива по 5 элементов в каждом. 1-ый массив задан с клавиатуры, 2-ой в 2 раза больше, чем первый, а 3-ий произведение 1-ого на 2-ой
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)