Задать вопрос
26 января, 08:44

Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел.

Написать в паскале.

+3
Ответы (2)
  1. 26 января, 11:34
    0
    Var

    a, b:real;

    begin

    Write ('Введите через пробел два числа: ') ; Read (a, b) ;

    if b=0 then Writeln ('Результат деления не определен')

    else

    if a*b>0 then Writeln ('Частное a/b имеет положительный знак')

    else

    if a=0 then Writeln ('Частное a/b равно нулю')

    else Writeln ('Частное a/b имеет отрицательный знак')

    end.

    Тестовое решение:

    Введите через пробел два числа: 8 - 4

    Частное a/b имеет отрицательный знак
  2. 26 января, 11:59
    0
    Var s1, s2:string;

    begin;

    writeln ('Введите исходные знаки') ;

    readln (s1) ;

    readln (s2) ;

    if ((s1'-') and (s1'+')) or ((s2'-') and (s2'+')) then

    begin;

    writeln ('Ошибка') ;

    exit;

    end;

    if ((s1='+') and (s2='+')) or ((s1='-') and (s2='-')) then writeln ('+') else writeln ('-') ;

    end.

    С числами:

    var a, b:integer;

    begin;

    writeln ('Делимое:') ;

    readln (a) ;

    writeln ('Делитель') ;

    readln (b) ;

    if b=0 then

    begin;

    writeln ('Нельзя делить на ноль. Если это, конечно, не jа vascript.') ;

    exit;

    end;

    if a=0 then

    begin;

    writeln ('0') ;

    exit;

    end;

    if ((a>0) and (b>0)) or ((a<0) and (b<0)) then writeln ('+') else writeln ('-') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел. Написать в паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Какой текст содержит больше информации: 1. Алфавит-64 знака Строк-20 Знаков в строке-30. 2. Алфавит-128 знаков Строк 15 Знаков в строке-20
Ответы (1)