Задать вопрос
25 мая, 02:58

Составьте программу генерирующую одномерный массив из элементов двумерного массива А (N, N), расположенных над главной диагональю

+1
Ответы (1)
  1. 25 мая, 03:39
    0
    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 const m = 100; var i, j, n: byte; arr1: array [1 ... m, 1 ... m] of integer; arr2: array [1 ... m] of integer; begin write ('Ко-во эл-ов квадратной матрицы: ') ; readln (n) ; for i:=1 to n do begin for j:=1 to n do begin arr1[i, j]:=random (50) ; write (arr1[i, j],' ') ; end; writeln; end; writeln ('Полученный массив:') ; for i:=1 to n do for j:=1 to n do if (j < n-i+1) then begin arr2[i]:=arr1[i, j]; write (arr2[i],' ') ; end; writeln; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу генерирующую одномерный массив из элементов двумерного массива А (N, N), расположенных над главной диагональю ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)