Задать вопрос
16 февраля, 23:16

Написать программу нахождения Ymax, если задана функция:

Y = Х2 - 100 Х + 10, где Х изменяется от Хнач. до Хкон. с шагом С. Программа должна так же выводить и значение Х, при котором Y принимает максимальное значение.

Значения Хнач., Хкон. и С должны задаваться пользователем при выполнении программы. Для организации цикла воспользуйтесь оператором While.

+3
Ответы (1)
  1. 17 февраля, 00:09
    0
    Var

    x0, xn, c:real;

    x, y, xmax, ymax:real;

    begin

    writeln ('Xнач, Xкон:') ;

    readln (x0, xn) ;

    write ('С = ') ; readln (c) ;

    x:=x0;

    xmax:=x; ymax:=x*x-100*x+10;

    while x
    begin

    x:=x+c;

    y:=x*x-100*x+10;

    if y>ymax then begin xmax:=x; ymax:=y; end;

    end;

    writeln ('xmax = ', xmax,' ymax = ', ymax) ;

    end.

    Пример:

    Xнач, Xкон:

    -10 20

    С = 1

    xmax = - 10 ymax = 1110
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу нахождения Ymax, если задана функция: Y = Х2 - 100 Х + 10, где Х изменяется от Хнач. до Хкон. с шагом С. Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы