Задать вопрос
24 мая, 05:20

Задача, паскаль

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры

+2
Ответы (1)
  1. 24 мая, 08:14
    0
    Var

    N : Longint;

    s : Set of Byte;

    F : Boolean;

    Begin

    s:=[]; F:=False;

    Readln (N) ;

    While (N>0) and not F do

    If not ((N mod 10) in s) then

    Begin

    Include (s, N mod 10) ;

    N:=N div 10;

    end else F:=True;

    Writeln (F) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача, паскаль Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программы в Pascal: 1. Ввести целое число и определить, верно ли, что все его цифры расположены в порядке возрастания ... 2. Ввести целое число и "перевернуть" его, так чтобы первая цифра стала последней и т. д.
Ответы (1)