Задать вопрос
19 мая, 20:10

Составить программу на паскале. Даны стороны двух треугольников. Найти сумму их периметров и сумму площадей. Определить процедуру для расчета периметра и площади треугольника по его сторонам

+5
Ответы (1)
  1. 19 мая, 21:53
    0
    Var z, x, c:real;

    procedure Perimetr (a, b, c:real) ;

    var p:real;

    begin

    p:=a+b+c;

    writeln ('P=', p) ;

    end;

    procedure Ploshad (a, b, c:real) ;

    var s, p:real;

    begin

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('S=', s) ;

    end;

    begin

    writeln ('Write first dа ta:') ;

    readln (z, x, c) ;

    Perimetr (z, x, c) ;

    Ploshad (z, x, c) ;

    writeln ('Write second dа ta:') ;

    readln (z, x, c) ;

    Perimetr (z, x, c) ;

    Ploshad (z, x, c) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на паскале. Даны стороны двух треугольников. Найти сумму их периметров и сумму площадей. Определить процедуру для ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Составить программу на паскале. Заданы длины сторон трех треугольников. Найти больший периметр. Для вычисления периметра треугольника используйте процедуру Perimetr, для определения большего из 2 чисел-процедура max
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
Помогите решить эту задачу в паскале! Для двух треугольников с катетами а, b, с, d. Найти сумму площадей треугольников. (Вычисление площади оформить в виде под программы-функция или процедура).
Ответы (1)
1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного. 2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3.
Ответы (1)