Задать вопрос
3 ноября, 18:11

Составить программу вычисляющую площадь произвольного треугольника со сторонами a b c в программе pascal

+2
Ответы (1)
  1. 3 ноября, 18:58
    0
    Program prog;

    uses crt;

    var

    a, b, c, s, p:real;

    begin

    write ('a = ') ;

    readln (a) ;

    write ('b = ') ;

    readln (b) ;

    write ('c = ') ;

    readln (c) ;

    if (a>0) and (b>0) and (c>0) then

    begin

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('S = ', s:0:3) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисляющую площадь произвольного треугольника со сторонами a b c в программе pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин
Ответы (1)
Составить программу, запрашивающую радиус окружности и вычисляющую длину окружности и площадь круга Сделать нужно в программе Free Pascal
Ответы (1)