Задать вопрос
17 февраля, 18:29

Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case.

+1
Ответы (1)
  1. 17 февраля, 19:52
    0
    Эта программа действительна при условии, что утро начинается в 6, день в 12, вечер в 18, а ночь в 24 и продолжается до 6. Написала через if, так как не знакома с case, буду рада, если кто-нибудь мне расскажет)

    var a: integer;

    begin

    read (a) ;

    if (a > 5) and (a < = 11) then

    write ('Утро ') ;

    if (a > 11) and (a < = 17) then

    write ('День ') ;

    if (a > 17) and (a < = 23) then

    write ('Вечер') ;

    if (a = 24) or (a < 6) then

    write ('Ночь') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Разработать программу, которая запрашивает ввод целого числа в переменную Z, определяет и выводит на экран сообщение, какое это число - положительное, отрицательное или равное 0.
Ответы (1)
Помогите составить программу в Pascal ABC Составить программу, которая определяет: a) символ по его коду, введенному с клавиатуры; b) символ для кода 100; c) код для символа ' ' (пробел).
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Напишите программу на Pascal, которая по введенному возрасту определяет, к какой возрастной группе относится человек: ребенок или взрослый.
Ответы (1)
Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n.
Ответы (1)