Задать вопрос
8 декабря, 08:34

Помогите выполнить это задание по информатике:

Составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив случайным образом и найти сумму элементов с нечётными номерами.

Прошу учесть правильность написания самой программы (Чтобы можно было вставить в паскаль и не исправлять чужие ошибки. (Я ещё в своих не разбираюсь))

+1
Ответы (1)
  1. 8 декабря, 11:07
    0
    Const N = 10;

    var i, sum: integer;

    M: array[1 ... 10] of integer;

    begin

    sum : = 0;

    for i : = 1 to N do begin

    M[ i ] : = random (11) ;

    write (M[i], ' ') ;

    if (M[ i ] mod 2 0) then sum : = sum + M[ i ];

    end;

    writeln () ;

    writeln ('Сумма всех нечетных элементов: ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите выполнить это задание по информатике: Составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
Для решения задачи задать случайным образом одномерный массив размерности N (вводится с клавиатуры) из целочисленных элементов, принадлежащих отрезку [-20; 20].
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)