Задать вопрос
23 октября, 01:27

В одномерном динамическом массиве, состоящем из n целочисленных элементов, вычислить количество отрицательных чисел. Программу написать на языке С/С++.

+1
Ответы (1)
  1. 23 октября, 05:12
    0
    С++

    #include

    using namespace std;

    int main ()

    {

    int n;

    int s=0;

    cout<<"Enter n"<
    cin>>n;

    cout<<"Enter elements"<
    int * a=new int [n];

    for (int i=0; i
    {

    cin>>a[i];

    if (a[i]<0)

    s=s+1;

    }

    cout<
    delete []a;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном динамическом массиве, состоящем из n целочисленных элементов, вычислить количество отрицательных чисел. Программу написать на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
В одномерном массиве М, состоящем из 10 целых чисел, найти: а) количество нулевых элементов: б) сумму элементов, больших - 4: В) полу сумму элементов с четными индексами: г) произведение нечетных элементов
Ответы (1)
В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве. Составить схему алгоритма и программу на языке программирования Basic для решения задачи по обработке одномерного массива.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Составить программу, позволяющую в одномерном массиве, состоящем из N вещественных элементов, вычислить: наименьший из элементов массива, принадлежащих отрезку [a, b]
Ответы (1)