Задать вопрос
1 мая, 03:58

Составить программу, позволяющую в одномерном массиве, состоящем из N вещественных элементов, вычислить: наименьший из элементов массива, принадлежащих отрезку [a, b]

+2
Ответы (1)
  1. 1 мая, 06:41
    0
    Pascal

    const n = 20;

    var

    a, b, min : real;

    m : array [1 ... n] of real;

    i : integer;

    begin

    / / формирова массива не пишу

    readln (a, b) ;

    min : = b;

    for i : = 1 to n do

    if (m[i]=a) and (m[i] <=b)

    then

    min : = m[i];

    writeln (min:3:2) ;

    end.

    Программа будет работать корректно, если в массиве есть хотя бы один элемент, попадающий в диапозон [a ... b].
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, позволяющую в одномерном массиве, состоящем из N вещественных элементов, вычислить: наименьший из элементов массива, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В одномерном массиве, состоящем из n вещественных элементов, вычислить: 1) Максимальный по модулю элемент массива 2) Сумму элементов массива, расположенных между первым и вторым положительными элементами.
Ответы (1)
В одномерном массиве, вводимом с клавиатуры и состоящем из 10 вещественных элементов, вычислить: 1) номер максимального по модулю элемента массива; 2) сумму элементов массива, расположенных после первого положительного элемента.
Ответы (1)