Задать вопрос
15 ноября, 22:12

Дан одномерный массив из 10 элементов. Подсчитать количество положительных элементов массива. Pascal

+2
Ответы (1)
  1. 16 ноября, 01:15
    0
    Const

    n = 10;

    var

    x: array[1 ... n] of integer;

    i, k: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    k : = 0;

    for i : = 1 to n do

    begin

    x[i] : = Random (51) - 25;

    Write (x[i]:4) ;

    if x[i]>0 then Inc (k)

    end;

    Writeln;

    Writeln ('Количество положительных элементов массива равно ', k) ;

    end.

    Тестовое решение:

    Элементы массива

    1 13 - 1 0 - 25 7 - 15 - 21 14 9

    Количество положительных элементов массива равно 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив из 10 элементов. Подсчитать количество положительных элементов массива. Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)