Задать вопрос
18 января, 18:19

Найти все трех значные числа где сумма первого и второго равна третьей

+2
Ответы (2)
  1. 18 января, 19:06
    0
    112,123,134,145,156,167,178,189

    213,224,235,246,257,268,279

    314,325,336,347,358,369

    415,426,437,448,459

    516,527,538,549

    617,628,639

    718,719

    819
  2. 18 января, 20:41
    0
    Var z1, z2:byte;

    begin

    for z1:=1 to 9 do begin

    for z2:=0 to 9-z1 do begin

    writeln (z1, z2, z1+z2) ;

    end;

    end;

    end.

    По просьбе автора задачи - вариант с 3 циклами

    var x, y, z:byte;

    begin

    for x:=1 to 9 do begin

    for y:=0 to 9 do begin

    for z:=0 to 9 do begin

    if (x+y=z) then writeln (x, y, z) ;

    end;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все трех значные числа где сумма первого и второго равна третьей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход два двузначных десятичных числа. По полученным числам строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма цифр первого числа и сумма цифр второго числа. 2.
Ответы (1)
Числа Вам даны число N и цифра D. Выведите все N - значные числа, которые не содержат цифру D, в возрастающем порядке. Формат входных данных В единственной строке входного файла записаны число N (1 ≤ N ≤ 7) и цифра D (0 ≤ D ≤ 9).
Ответы (1)
Да ну трёх значные числа. Напишите программу, который определяет: А) Есть ли среди цифр заданного целого трёх значного числа одинаковый 123 нет 121 да 222 да Б) Является ли число перевертышем то есть число десятичной записи которые читаются
Ответы (1)
Напишите программу, которая позволяет ввести три вещественных числа и выводит на экран: разность целых частей первого и второго чисел; косинус удвоенного произведения первого на третье; сумму квадратов синуса второго числа и косинуса третьего.
Ответы (1)
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)