Задать вопрос
20 августа, 19:03

Программа в Паскаль

Напишите программу, которая возводит введенное число в степень 10, используя только четыре операции умножения.

Входные данные

Входная строка содержит единственное вещественное число в диапазоне от 0 до 8.

Выходные данные

Нужно вывести 10-ю степень полученного числа с тремя знаками в дробной части.

+4
Ответы (1)
  1. 20 августа, 22:42
    0
    Var A, B:real;

    Begin

    Read (A) ;

    B:=A*A;

    B:=B*B;

    B:=B*A;

    B:=B*B;

    Write (A,'^10 = ', B:0:3) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа в Паскаль Напишите программу, которая возводит введенное число в степень 10, используя только четыре операции умножения. Входные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая возводит натуральное число A в натуральную степень B. Входные данные Входная строка содержит два числа, A и B, разделённые пробелом. Гарантируется, что 1 ≤ A, B ≤ 1000.
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Напишите программу, которая выводит все простые числа в диапазоне от 2 до N (N заранее неизвестно). Входные данные Входная строка содержит целое число N.
Ответы (1)