Задать вопрос
5 февраля, 15:19

1) дано целое число, если оно положительное то прибавить к нему 1, а если в противном случаи, то не изменять и написать результат

2) дано число от 1 до 7 (ввести)

В зависимости от значений напичатать дни недели пониднльник-1 и т. д.

+5
Ответы (1)
  1. 5 февраля, 18:48
    0
    Pascal:

    1)

    var a:integer;

    begin

    readln (a) ;

    if a>0 then a:=a+1;

    writeln ('Ответ:', a) ;

    end.

    2)

    var a:integer;

    begin

    readln (a) ;

    case a of

    1:writeln ('Понедельник') ;

    2:writeln ('Вторник') ;

    3:writeln ('Среда') ;

    4:writeln ('Четверг') ;

    5:writeln ('Пятница') ;

    6:writeln ('Суббота') ;

    7:writeln ('Воскресенье')

    else writeln ('Ошибка') ;

    end;

    end.

    //Могу написать тоже самое на c + + если нужно.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) дано целое число, если оно положительное то прибавить к нему 1, а если в противном случаи, то не изменять и написать результат 2) дано ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Решить задачи: 1. Дано целое число. Если оно является положительным, то прибавить к нему 8, если нет, то не изменять. Вывести полученное число. 2. Дано целое чило.
Ответы (1)
Дано целое положительное число. Проверить истинность высказывания: "данное число является нечетным трехзначным". Входные данные: ввести одно целое положительное число a ((1
Ответы (1)
1) Определить, является ли введенное с клавиатуры число трехзначным? 2) Дано целое число. Если оно является положительным, то прибавить к нему 1; в противном случае не изменять его. Вывести полученное число.
Ответы (1)
Дано целое число. Если оно является положительным, то прибавить к нему 1; в противном случае не изменять его. Вывести полученное число. Люди прошу помогите, пипец как надо!
Ответы (2)