Задать вопрос
5 февраля, 15:56

Дан текст, состоящий из букв и цифр. Найти наименьшую цифру.

+2
Ответы (1)
  1. 5 февраля, 17:08
    0
    Var

    a:string;

    i, n, j:integer;

    buf:char;

    begin

    readln (a) ;

    n:=length (a) ;

    for i:=n downto 1 do

    if (a[i]'9') then

    delete (a, i, 1) ; {удалила символы кроме цифр}

    n:=length (a) ;

    for i:=1 to n-1 do

    for j:=i+1 to n do

    if a[i]>a[j]then {сортирую по возрастанию, на первом месте самая

    begin маленькая}

    buf:=a[i];

    a[i]:=a[j];

    a[j]:=buf;

    end;

    writeln (a[1]) ; {вывожу первую цифру}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан текст, состоящий из букв и цифр. Найти наименьшую цифру. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Нужна помощь! 1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10. Все его элементы уменьшить на число 20. 2. дан массив состоящий из 8 вещественных чисел. все элементы с четными номерами уменьшить на 1, с нечетными-увеличить на 1.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)