Задать вопрос
29 октября, 21:56

Составить программу в Паскале.

Заменить в тексте слово "sin" на слово "cos" и подсчитать количество замен.

+5
Ответы (1)
  1. 29 октября, 22:15
    0
    Var y, x: string;

    i, k: integer;

    begin

    k=0;

    read (x) ;

    for i:=1 to length (x) do

    begin

    y:=copy (x, i, 3) ;

    If (y='sin') then begin

    delete (x, i, 3) ;

    insert ('cos', x, i) ;

    k:=k+1;

    end;

    writeln (x) ;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Паскале. Заменить в тексте слово "sin" на слово "cos" и подсчитать количество замен. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напечатайте индексы всех равных элементов произвольного массива A (N; N). 2. В заданном тексте заменить последовательность символов X (I) на A (I), подсчитать количество произведенных замен. эти две задачи необходимо решить в турбо паскале
Ответы (1)
Составить подпрограмму, заменяющую все элементы одномерного массива, меньшие заданной величины Т, на значение этой величины и считающую число таких замен.
Ответы (1)
В тексте слово "2009" встречалось 27 раз, а слово "2010" ⴀ31 раз. Заменили 2009 на 2010, затем 2010 на 2011. Сколько замен было выполнено замен в последний раз. 1) 27 раз; 2) 31 раз; 3) 58 раз; 4) 5 раз
Ответы (2)
Записать в виде обычной математической формулы 1) y:=2*sin (x) * sqrt (x+sqrt (abs (x))) 2) y: = sqrt (sin (x) + sin (sqrt (x))) 3) y: = sqrt (abs (x-1) + sqrt (sin (x))) 4) y: = (5*sin (x) + 4) / 2*15*sin (sqrt (x)) 5) k+15*x / (2*sin (x)) 6) y:=
Ответы (1)
Составить программу в паскале, в которой: а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345. б) Подсчитать и вывести отрицательные элементы массива
Ответы (1)