Задать вопрос
29 октября, 21:27

Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч). Используя текстовые файлы input, output.

+3
Ответы (1)
  1. 30 октября, 01:04
    0
    Program Pr1;

    uses crt;

    var fl1, fl2:text;

    n, tmp:string;

    Begin

    clrscr;

    assign (fl1,'input. txt') ;

    assign (fl2,'output. txt') ;

    reset (fl1) ;

    readln (fl1, n) ;

    close (fl1) ;

    tmp:=copy (n, length (n),1) ;

    n:=tmp+n;

    rewrite (fl2) ;

    writeln (fl2, n) ;

    close (fl2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти сумму чисел в текстовом документе. Почему пишет неизвестный идентификатор. var a, b:integer; begin assign (input,'input. txt') ; reset (input) ; assign (output,'output.
Ответы (1)
Помогите отредактировать программу - Паскаль. Где-то ошибка. Необходимо удалить первый кратный 3 элемент массива. program udalenie; var i, n, k:integer; a:array[1 ... 1000] of integer; begin assign (input,'input. txt') ; assign (output,'output.
Ответы (1)
Нужно определить что в введеном числе 24 часовой формат или 12 часовой формат и составить код в с++ Задача такое: №1 Input (стандартный ввод) Output (вывод) 11:00 24-часовый формат 23:00 №2 Input (стандартный ввод) Output (вывод) 09:20 12-часовый
Ответы (1)
Расширения. txt,. rtf,. doc имеют: (Расширение определяет принадлежность к какому-либо типу файлов и пишется после названия файла) исполняемые файлы; текстовые файлы; звуковые файлы; графические файлы.
Ответы (2)
Помогите откорректировать программу - Паскаль. Структура программы как у меня. Условие: Дан одномерный массив, состоящий из вещественных элементов. Найти сумму элементов массива, расположенных до последнего положительного элемента.
Ответы (2)