Задать вопрос
1 октября, 04:58

Дан двумерный массив. Найти столбец с максимальной и минимальной суммой элементов.

+2
Ответы (1)
  1. 1 октября, 08:13
    0
    Begin

    var a: array [,] of integer : = (

    (1, 10, 100),

    (1, 10, 200),

    (1, 9, 100),

    (1, 9, 100)) ;

    var max : = integer. MinValue;

    var countmax : = 0;

    var min : = integer. MaxValue;

    var countmin : = 0;

    var counter : = 0;

    for var j : = 0 to a. GetLength (1) - 1 do

    begin

    counter + = 1;

    var c : = 0;

    for var i : = 0 to a. GetLength (0) - 1 do

    begin

    c + = a[i, j]

    end;

    if max < c then

    begin

    max : = c;

    countmax : = counter;

    end;

    if min > c then

    begin

    min : = c;

    countmin : = counter;

    end;

    end;

    writeln ('Столбик с наибольшей суммой - ', countmax) ;

    writeln ('Столбик с наименьшей суммой - ', countmin) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный массив. Найти столбец с максимальной и минимальной суммой элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)