Задать вопрос
1 июня, 16:31

Напишите программу решения задачи на языке Паскаль: Даны два целых двузначных числа. Переставить местами цифры наибольшего из них. Если полученное число останется наибольшим вывести "YES", в противоположном случае вывести "NO".

+1
Ответы (1)
  1. 1 июня, 18:32
    0
    Var

    a, b, max, min:integer;

    begin

    Write ('Введите два целых двухзначных числа: ') ; Readln (a, b) ;

    if a>b then begin max:=a; min:=b end

    else begin max:=b; min:=a end;

    if (10 * (max mod 10) + (max div 10)) >min then Writeln ('YES')

    else Writeln ('NO')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу решения задачи на языке Паскаль: Даны два целых двузначных числа. Переставить местами цифры наибольшего из них. Если ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Напишите программу для решения задачи. С2. Даны целые числа a, b, с. Если а≤b≤c, то все числа замените квадратами, если а>b>c, то каждое число замените наибольшим из них, в противном случае смените знак каждого числа. С2.
Ответы (1)