Задать вопрос
25 августа, 19:53

Напишите программу для решения задачи. С2. Даны целые числа a, b, с. Если а≤b≤c, то все числа замените квадратами, если а>b>c, то каждое число замените наибольшим из них, в противном случае смените знак каждого числа. С2. По номеру месяца выдайте квартал, которому он принадлежит.

+5
Ответы (1)
  1. 25 августа, 22:07
    0
    Var a, b, c:integer;

    begin

    readln (a, b, c) ;

    if (a<=b) and (b<=c) then

    begin

    a:=a*a;

    b:=b*b;

    c:=c*c;

    end

    else if (a>b) and (b>c) then

    begin

    if a
    if a
    b:=a; c:=a;

    end

    else

    begin

    a:=a * (-1) ;

    b:=b * (-1) ;

    c:=c * (-1)

    end;

    writeln (a:4, b:4, c:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для решения задачи. С2. Даны целые числа a, b, с. Если а≤b≤c, то все числа замените квадратами, если а>b>c, то каждое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны целые числа a, b, c. Если a ≤ b ≤ c, то все числа заменить rкубами, если a>b>c, то смените знак каждого числа, в противном случае каждое число заменить наибольшим и них.
Ответы (1)
даны целые числа a, b, c. Если аc, то смените знак у каждого, в противном случае каждое замените наименьшим из них.
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если А>В>C>0, то замените все числа их квадратами и выведите результаты на экран.
Ответы (1)
Помогите написать задачу на языке Паскаль: Даны действительные числа a, b, c, d. Если ad, то каждое число заменить средним арифметическим всех значений. В противном случае все числа заменяются своими квадратами
Ответы (2)
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)