Задать вопрос
1 июля, 09:26

Запишите программу формирования и вывода массива из 20 случайных чисел (из диапазона от 0 да 1000) и вычисления их среднего значения

+3
Ответы (1)
  1. 1 июля, 13:24
    0
    Var

    m:array[1 ... 100] of integer;

    i, s, n:longint;

    a:real;

    begin

    randomize;

    writeln ('Массив:') ;

    for i:=1 to 20 do

    begin

    m[i]:=random (1001) ;

    write (m[i],' ') ;

    s:=s+m[i];

    end;

    a:=s/20;

    writeln ('Среднее арифметическое: ', a:2:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Запишите программу формирования и вывода массива из 20 случайных чисел (из диапазона от 0 да 1000) и вычисления их среднего значения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
1) напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением.
Ответы (1)