Задать вопрос
27 мая, 22:59

Составить программу паскаль: подсчитать количество положительных и количество отрицательных элементов массива

+5
Ответы (1)
  1. 27 мая, 23:28
    0
    Var

    N, i, c1, c2:integer;

    mas:array[1 ... 9999] of integer;

    begin

    readln (N) ;

    for i:=1 to N do

    begin

    readln (mas[i]) ;

    if mas[i]>0 then

    c1:=c1+1;

    if mas[i]<0 then

    c2:=c2+1;

    end;

    writeln ('Положительных элементов: ', c1) ;

    writeln ('Отрицательных элементов: ', c2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу паскаль: подсчитать количество положительных и количество отрицательных элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)