Задать вопрос
23 ноября, 19:56

Как составить программу вычисления и выдачи на печать суммы (или произведения) N элементов бесконечного числового ряда. Следует пользоваться операторами цикла FOR:y=125 (-25) 5 (-1) 0,2 ...

+4
Ответы (1)
  1. 23 ноября, 20:52
    0
    1 var k, i, n, c:integer;

    2 p, w:real;

    3 begin

    4 repeat

    5 write ('k>-3 k=') ;

    6 readln (k) ;

    7 until k>-3;

    8 w:=0;

    9 c:=1;

    10 for i:=-3 to k do

    11 begin

    12 c:=-c; {-1^i}

    13 p:=1;

    14 for n:=i to 2*k do

    15 if n2 then p:=p * (n*n*n-8) ;

    16 if i5 then w:=w + (c/sqr (i-5)) * p;

    17 end;

    18 write ('W=', w:0:4)

    19 end.

    Это?
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как составить программу вычисления и выдачи на печать суммы (или произведения) N элементов бесконечного числового ряда. Следует ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить программу вычисления числового ряда для известного числа ряда N. Y = (1-2/5) + (2+4/10) + (3-8/15) + (4+16/20) + ..
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1) составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных чисел. Pascal 2) составьте программу вычисления суммы элементов от первого отрицательного и до конца. Pascal
Ответы (1)