Задать вопрос
15 января, 03:04

Дана строка, содержащая текст, заканчивающийся точкой. Вывести на экран слова, содержащие три буквы.

+2
Ответы (2)
  1. 15 января, 03:38
    0
    Var a, d, e:string;

    c:real;

    f:integer;

    begin

    writeln ('введите предложение отделяя каждое слово новой строкой') ;

    readln (a) ;

    c:=0;

    while (ab) do begin

    if length (a) = 3 then

    c:=c+1;

    readln (a) ;

    end;

    writeln (c) ;

    end.

    тут один минус, каждое новое слово надо вводить через enter совершенно не используя пробела и точку тоже чнрез enter
  2. 15 января, 06:52
    0
    var

    s : string;

    k, l, i, p : integer;

    begin

    readln (s) ;

    l : = Length (s) ;

    k : = 0;

    for i : = 1 to l do

    begin

    if (s[i] ' ') and (s[i] '.') then

    k : = k + 1

    else

    begin

    if k = 3 then

    begin

    for p : = i-3 to i-1 do

    write (s[p]) ;

    write (' ') ;

    end;

    k : = 0;

    end;

    end;

    end.

    Вводиться строка, считается что все слова разделены пробелом между собой, и строка оканчиватся точкой.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка, содержащая текст, заканчивающийся точкой. Вывести на экран слова, содержащие три буквы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)