Задать вопрос
11 сентября, 09:02

Составить программу, позволяющую определить, есть ли среди цифр задорного целого трехзначного числа Х четные?

+5
Ответы (2)
  1. 11 сентября, 09:24
    0
    Var

    n, d1, d10, d100:integer;

    begin

    Write ('Введите натуральное трехзначное число: ') ; Read (n) ;

    d1:=n mod 10; d100:=n div 100;

    d10: = (n div 10) mod 10;

    if (d1 mod 2 = 0) or (d10 mod 2=0) or (d100 mod 2=0)

    then Writeln ('Есть четная цифра')

    else Writeln ('Нет четных цифр')

    end.
  2. 11 сентября, 12:47
    0
    Var

    x, ed, des, sot:integer;

    Begin

    Readln (x) ;

    ed:=x mod 10;

    des:=x div 10 mod 10;

    sot:=x div 100 mod 10;

    x:=0;

    if sot mod 10=1 then x:=x+0 else x:=x+1;

    if des mod 10=1 then x:=x+0 else x:=x+1;

    if ed mod 10=1 then x:=x+0 else x:=x+1;

    if x>0 then writeln ('Есть') else writeln ('Нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, позволяющую определить, есть ли среди цифр задорного целого трехзначного числа Х четные? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Опишите переменные для размещения в них: - пола человека (один символ) ; - целого положительного двузначного числа; -целого положительного трёхзначного числа; -целого положительного четырёхзначного числа; -небольшого вещественного числа;
Ответы (1)
Дано целое положительное трехзначное число. Напишите программу, позволяющую определить число, полученное выписыванием в обратном порядке цифр заданного трехзначного числа. Например: 123->321.
Ответы (1)
Напишите программу, позволяющую по последней цифре трехзначного числа определить последнюю цифру его произведения на число 3 (например, для числа 234, последней цифрой при произведении на 3 будет цифра 2)
Ответы (1)