Задать вопрос
20 февраля, 00:36

Дано 4 х злачное число, подсчитать среднеарифметическое четных чисел. + выполнить проверку

+4
Ответы (1)
  1. Ф
    20 февраля, 03:24
    0
    Program ops;

    var a, b, c, d:integer;

    s: real; begin

    writeln ('введите четырёхзначное число') ;

    readln (a) ;

    b:=a mod 10;

    a:=a div 10;

    c:=a mod 10;

    a:=a div 10;

    d:=a mod 10;

    a:=a div 10;

    s: = (b+c+d+a) / 4;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 4 х злачное число, подсчитать среднеарифметическое четных чисел. + выполнить проверку ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)
1) Составить массив из 10 целых чисел, вывести его на экран и подсчитать количество элементов массива, значения которых не превышают трех 2) Составить массив из 10 целых чисел и вывести его на экран, подсчитать сумму отрицательных и положительных
Ответы (1)
Вариант № 2 1) Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87. Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.
Ответы (1)
Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток.
Ответы (1)
Напишите программу на паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток.
Ответы (1)
 
Войти
Задать вопрос