Задать вопрос
20 февраля, 02:04

Даны целые числа а и в (а<в) написать программу вычисления всех целых чисел от а до в включительно

+3
Ответы (2)
  1. 20 февраля, 03:02
    0
    Var a, b, c:integer;

    begin

    writeln ('введите число a') ;

    readln (a) ;

    writeln ('введите число b') ;

    readln (b) ;

    for a:=a to b do begin

    writeln ('число в промежутке = = >', a) ;

    end;

    if a>b then

    for b:=b to a do begin

    writeln ('число в промежутке = = >', b) ;

    end;

    end.
  2. 20 февраля, 05:33
    0
    Var

    a, b, i: integer;

    begin

    writeln ('введите число a') ;

    readln (a) ;

    writeln ('введите число b') ;

    readln (b) ;

    if (a > b) then begin

    i : = b;

    b : = a;

    a : = i;

    end;

    for i : = a to b do

    writeln ('число в промежутке = = >', i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны целые числа а и в (а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны свойства поля в Ворде к ним надо подобрать правильные варианты1) целые числа 0 до 225 2) целые числа от - 32768 до 32767 3) целые числа от - 2147483648 до 2147483647 4) числа от - 1,797*10308 до 1,797*10308 Byte - Long Integer - Double -
Ответы (1)
Числа в языке Pascal различаются: А) как натуральные и целые; Б) как целые и вещественные; В) как натуральные и вещественные; Г) как целые и иррациональные; Д) как целые и рациональные.
Ответы (1)
Даны целые числа a и b. Найти их удвоенную сумму. Дано: a и b-целые числа (integer) Найти: u-удвоенную сумму (сумма целых чисел s - целое число, удвоенное целое - целое число integer)
Ответы (1)
Написать на C++ задания с ассемблерным вставками. 1. Даны целые числа k, l. Если числа не равны, то заменить каждое из них одним и тем же числом, равным большему из исходных, а если равны, то заменить числа нулями. (Операции с целыми числами) 2.
Ответы (1)
Вариант 2 1. Даны три числа. Найдите сумму второго и третьего числа. Найдите квадрат первого числа. 2. Даны длины сторон прямоугольника. Найдите площадь прямоугольника. 3. Даны длины катетов прямоугольного треугольника. Найдите периметр треугольника.
Ответы (1)