Задать вопрос
1 мая, 22:22

В одномерном массиве, состоящем из n вещественных элементов, вычислить:

1) номер минимального элемента массива

+2
Ответы (1)
  1. 2 мая, 00:00
    0
    program zadacha;

    var min, n: real;

    a: array[ 1 ... 10 ] of real;

    i: integer;

    begin

    writeln ('Введите элементы массива') ;

    for i:=1 to 10 do

    begin

    write ('a[', i,']=') ;

    readln (a[i]) ;

    end;

    n:=1;

    min:=a[i];

    for i:=2 to 10 do

    if min>a[i] then

    begin

    min:=a[i];

    n:=i;

    end;

    writeln ('Номер минимального элемента массива ', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве, состоящем из n вещественных элементов, вычислить: 1) номер минимального элемента массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
В одномерном массиве, вводимом с клавиатуры и состоящем из 10 вещественных элементов, вычислить: 1) номер максимального по модулю элемента массива; 2) сумму элементов массива, расположенных после первого положительного элемента.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В одномерном массиве, состоящем из n вещественных элементов, вычислить: 1) Максимальный по модулю элемент массива 2) Сумму элементов массива, расположенных между первым и вторым положительными элементами.
Ответы (1)