Задать вопрос
4 сентября, 09:37

Дано Х и N. Составить программу для Х в степени N на Паскале.

+3
Ответы (2)
  1. 4 сентября, 11:23
    0
    О типах x и n неизвестно ничего, но по сложившейся традиции резонно предположить, что n - целое, x - вещественное. Представленная программа написана именно в таком понимании типов переменных.

    var

    i, n:integer;

    x, p:double;

    begin

    Write ('Введите основание (x) и показатель степени (n) : ') ;

    Read (x, n) ;

    if x=0 then p:=0

    else begin

    p:=1;

    for i:=1 to Abs (n) do p:=p*x;

    if n<0 then p:=1/p

    end;

    Writeln (x,'^', n,'=', p)

    end.

    Тестовые решения:

    Введите основание (x) и показатель степени (n) : 2 30

    2^30=1073741824

    Введите основание (x) и показатель степени (n) : - 3.35 9

    -3.35^9=-53137.7624927636

    Введите основание (x) и показатель степени (n) : 18.3 - 4

    18.3^-4=8.9165251950717E-06
  2. 4 сентября, 12:25
    0
    Var x, n, res, i: integer;

    begin

    res:=1;

    readln (x) ;

    readln (n) ;

    for i: = 1 to n do

    res:=res*x;

    writeln (x, '^', n, ' = ', res) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано Х и N. Составить программу для Х в степени N на Паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
23 в 4 степени+21 в 8 степени = ответ в 10 степени 12 в 10 степени * 1010 в 2 степени = ответ в 3 степени (10101 в 2 степени + 212 в 3 степени) * 2 в 10 степени = ответ в 5 степени
Ответы (1)
Составить программу вычесления суммы составить программу вычесления суммы ряда s=4 в 1 степени+4 в 3 степени + 4 в 5 степени ... + 4 в 15 степени
Ответы (2)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)