Задать вопрос
12 марта, 06:09

Программирование в паскале:

1.1 Даны 2 слова. Определить, какое из двух слов длиннее и на сколько.

1.2 Записано предложение. По последнему символу определить тип предложения. (повествовательное, вопросительное или восклицательное)

1.3 Поменять в слове первую и последнюю буквы

+5
Ответы (1)
  1. 12 марта, 09:00
    0
    var

    a, b: string;

    c: integer;

    begin

    writeln ('Введите первое слово: ') ;

    readln (a) ;

    writeln ('Введите второе слово: ') ;

    readln (b) ;

    c : = length (a) - length (b) ;

    if c = 0 then writeln ('Длины слов равны')

    else if c > 0 then writeln ('Первое слово длиннее второго на ', c)

    else writeln ('Второе слово длиннее первого на ', - c)

    end.

    2)

    var a: string;

    begin

    writeln ('Введите предложение: ') ;

    readln (a) ;

    case a[length (a) ] of

    '.': writeln ('Предложение повествовательное') ;

    '!': writeln ('Предложение восклицательное') ;

    '?': writeln ('Предложение вопросительное') ;

    end;

    end.

    3)

    var

    a: string;

    t: char;

    begin

    writeln ('Введите слово: ') ;

    readln (a) ;

    t : = a[1];

    a[1] : = a[length (a) ];

    a[length (a) ] : = t;

    writeln ('Полученное слово: ', a)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программирование в паскале: 1.1 Даны 2 слова. Определить, какое из двух слов длиннее и на сколько. 1.2 Записано предложение. По последнему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано 4 значное число, поменять местами первую и последнюю цифру. Программирование, составить в Паскале
Ответы (1)
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после
Ответы (1)
Паскаль: Дано слово. Удалить из него третью букву. (Условие (желательно но необязательно) : присваивание последнему символу исходной строки значение "_".)
Ответы (1)
Дан список слов кран склон кратер кража 1 в слове не пять букв 2 в слове две гласных и четыри буквы согласных 3 в слове две гласных или четыри буквы согласных 4 в слове четыри буквы и не две буквы согласных
Ответы (1)
По горизонтали: 1. Объект Windows (4, буквы) 2. А4 - это ... (6, буквы) 3. Есть у человека и компьютера. (6, буквы) 4. Начни работу с этой кнопки ... (4, буквы) 5. Чтобы работать с объектом, его надо ... (8, буквы) 6. Есть в ресторане и компьютере.
Ответы (1)