Задать вопрос
20 октября, 20:58

Составить программу вычисления значений квадратичной функции на заданном интервале

+4
Ответы (1)
  1. 21 октября, 00:33
    0
    Var

    a, b, c, p, q, h, x, y:real;

    begin

    Write ('Введите через пробел коэффициенты a, b, c: ') ;

    Read (a, b, c) ;

    Write ('Введите через пробел границы интервала [p; q]: ') ;

    Read (p, q) ;

    Write ('Введите шаг табуляции h: ') ;

    Read (h) ;

    x:=p;

    while x<=q+h/10 do begin

    y:=c+x * (b+x*a) ; { схема Горнера для вычисления значения полиномов }

    Writeln (x:15:8, y:15:8) ;

    x:=x+h

    end

    end.

    Тестовое решение:

    Введите через пробел коэффициенты a, b, c: - 4 2.7 10.582

    Введите через пробел границы интервала [p; q]: - 3 2.5

    Введите шаг табуляции h: 0.25

    -3.00000000 - 33.51800000

    -2.75000000 - 27.09300000

    -2.50000000 - 21.16800000

    -2.25000000 - 15.74300000

    -2.00000000 - 10.81800000

    -1.75000000 - 6.39300000

    -1.50000000 - 2.46800000

    -1.25000000 0.95700000

    -1.00000000 3.88200000

    -0.75000000 6.30700000

    -0.50000000 8.23200000

    -0.25000000 9.65700000

    0.00000000 10.58200000

    0.25000000 11.00700000

    0.50000000 10.93200000

    0.75000000 10.35700000

    1.00000000 9.28200000

    1.25000000 7.70700000

    1.50000000 5.63200000

    1.75000000 3.05700000

    2.00000000 - 0.01800000

    2.25000000 - 3.59300000

    2.50000000 - 7.66800000
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления значений квадратичной функции на заданном интервале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Составить программу для вычисления значений переменной y при заданном значении n. (использовать три различных оператора цикла) y=
Ответы (1)