Задать вопрос
23 января, 15:11

Составить программу для вычисления значений переменной y при заданном значении n. (использовать три различных оператора цикла)

y=

+4
Ответы (1)
  1. 23 января, 17:24
    0
    Var

    y:real;

    n, i:integer;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    {Цикл с параметром:}

    y:=0;

    For n: = 1 to n do

    y:=y + (1/n) ;

    WriteLn ('y = ', y) ;

    {Цикл с постусловием:}

    y:=0;

    i:=1;

    Repeat

    y:=y + (1/i) ;

    i:=i+1

    Until i>n;

    WriteLn ('y = ', y) ;

    {Цикс с предусловием:}

    y:=0;

    i:=1;

    While i<=n do

    Begin

    y:=y + (1/i) ;

    i:=i+1

    End;

    WriteLn ('y = ', y)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для вычисления значений переменной y при заданном значении n. (использовать три различных оператора цикла) y= ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Составить схему алгоритма и программу для вычисления значений функций Y и F для заданных значений переменной x и постоянных a и b. Значения переменной x>=0. Вывести на экран значения F, Y для соответствующих значений x.
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)