Задать вопрос
11 февраля, 05:35

Задано натуральное четырехзначное число. В нем заменили все цифры, большие 5, на 1. Найти полученное число

+4
Ответы (2)
  1. 11 февраля, 07:54
    0
    Var x, a, c, t:integer;

    begin

    readln (x) ;

    c:=0;

    t:=1;

    while x0 do begin

    a:=x mod 10;

    if a > 5 then

    a:=1;

    c:=a*t+c;

    t:=t*10;

    x:=x div 10; end;

    write (c) ;

    readln

    end.
  2. 11 февраля, 08:57
    0
    Program p13;

    const n=4;

    var s:string;

    i:integer;

    begin

    writeln ('wwedite stroku') ;

    readln (s) ;

    for i:=1 to length (s) do

    if s[i]>'5' then s[i]:='1';

    writeln ('s=', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задано натуральное четырехзначное число. В нем заменили все цифры, большие 5, на 1. Найти полученное число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания 2. Задано четырехзначное число. Удалить из записи числа последнюю цифру.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
C + + Дано натуральное четырехзначное число. Найдите минимальное натуральное четырехзначное число, состоящее из тех же цифр, что и заданное. Заметим, что четырехзначные числа не могут начинаться с нуля.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)