Задать вопрос
31 июля, 02:17

Дана последовательность n вещественных чисел определить количество отрицательных чисел в этой последовательности

+5
Ответы (1)
  1. 31 июля, 03:25
    0
    Program z1;

    var a, i, otr: integer;

    b: array [1 ... 100] of integer;

    begin

    read (a) ;

    for i:=1 to a do

    read (b[i]) ;

    otr:=0;

    for i:=1 to a do

    if b[i]<=0 then inc (otr) ;

    writeln ('Количество отрицательных ', otr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность n вещественных чисел определить количество отрицательных чисел в этой последовательности ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Дана последовательность из n вещественных чисел, начинающаяся с отрица- тельного числа. Определить, какое количество отрицательных чисел записано в начале последовательности. Условный оператор не использовать.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Дана последовательность вещественных чисел а. Найти среднее арифметическое не отрицательных членов этой последовательности.
Ответы (1)