Задать вопрос
21 декабря, 07:18

Дана последовательность вещественных чисел а. Найти среднее арифметическое не отрицательных членов этой последовательности.

+4
Ответы (1)
  1. 21 декабря, 07:23
    0
    Var a, k, s, i:integer; Begin Readln (a) ; For i:=1 to a do begin Read (i) ; If i>=0 then begin k:=k+i; inc (s) ; end; End; A:=k div s; Write (a) ; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность вещественных чисел а. Найти среднее арифметическое не отрицательных членов этой последовательности. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное n и последовательность чисел x1, x2, ..., xn. Вычислить среднее арифметическое членов последовательности. В первой строке содержится целое число n (1≤n≤100) - количество членов последовательности.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Дана последовательность n вещественных чисел определить количество отрицательных чисел в этой последовательности
Ответы (1)
1. На входе непустая последовательность натуральных чисел с нулем в конце. Вывести MIN и среднее арифметическое. Представить блок-схему и pascal-программу. 2. На входе последовательность вещественных чисел с нулем в конце.
Ответы (1)