Задать вопрос
18 июля, 17:45

Дана последовательность из n вещественных чисел, начинающаяся с отрица-

тельного числа. Определить, какое количество отрицательных чисел записано

в начале последовательности. Условный оператор не использовать.

+2
Ответы (1)
  1. 18 июля, 18:46
    0
    const

    n = 5;

    var

    a, i, k : integer;

    begin

    readln (a) ;

    k : = 1;

    While (a < 0) and (k < n) do

    begin

    k : = k + 1;

    readln (a) ;

    end;

    for i : = k to n do

    readln (a) ;

    a : = k;

    While a
    begin

    k : = k - 1;

    a : = n;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность из n вещественных чисел, начинающаяся с отрица- тельного числа. Определить, какое количество отрицательных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)
Вводится последовательность целых ненулевых чисел, 0 - конец последовательности. Определить, сколько раз последовательность поменяет знак. Ограничения! Нельзя использовать условный оператор (If) и оператор выбора (Case).
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)