Задать вопрос
20 мая, 09:23

Удалите из символьной строки все символы, которые являются одной из четырех первых букв латинского алфавита. На паскале помогите

+4
Ответы (1)
  1. 20 мая, 11:28
    0
    Var

    dc:set of char;

    s1, s2:string;

    i:integer;

    begin

    dc:=['A' ... 'D','a' ... 'd'];

    s1:='То avoid the impression of the tail wagging the dog, '+

    'the president cannot be seen bending to the wishes of a minority.';

    s2:='';

    for i:=1 to length (s1) do

    if not (s1[i] in dc) then s2:=s2+s1[i];

    Writeln ('Исходная строка: ', s1) ;

    s1:=s2;

    Writeln ('Результирующая строка: ', s1)

    end.

    Тестовое решение:

    Исходная строка: То avoid the impression of the tail wagging the dog, the president cannot be seen bending to the wishes of a minority.

    Результирующая строка: То voi the impression of the til wgging the og, the presient nnot e seen ening to the wishes of minority.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Удалите из символьной строки все символы, которые являются одной из четырех первых букв латинского алфавита. На паскале помогите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На паскале Даны две строки. Определите, является ли первая строка подстрокой второй строки. Входные данные На вход подается 2 строки длины не более 10000, состоящие только из маленьких букв латинского алфавита.
Ответы (2)
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)
Имя файла может содержать символы ... только русского алфавита только латинского алфавита компьютерного алфавита
Ответы (1)
Выбери нужное продолжение. Имя файла может содержать символы ... а) только русского алфавита, б) только латинского алфавита, в) компьютерного алфавита
Ответы (2)
Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово - это последовательность непробельных символов, ограниченная пробелами или концами строки.
Ответы (1)