Задать вопрос
21 августа, 05:24

Составить программу, которая будет вводить N чисел и искать максимальное число среди этих чисел.

1<=a[i], N<=100

+2
Ответы (1)
  1. 21 августа, 09:16
    +1
    Const

    n=100;

    var

    a:array[1 ... n] of integer;

    max, i:integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    writeln (a[i]='') ;

    readln (a[i]) ;

    end;

    max:=a[1];

    for i:=2 to n do

    If a[i]>max then begin

    max:=a[i];

    end;

    writeln;

    writeln ('Max=', max) ;

    readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая будет вводить N чисел и искать максимальное число среди этих чисел. 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Составить программу, которая будет вводить десять чисел и подсчитывать количество пятерок среди этих чисел. Пример ввода: 1 6 10 5 7 42 5 9 5 11 Пример вывода: 3 (Паскаль)
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
В саду распустились 19 астр и 21 георгинов. Девочка сорвала 20 цветов. Выберите верные утверждения: Среди этих цветов обязательно есть два георгина Среди этих цветов точно есть 1 георгин Среди этих цветов точно есть 1 астра Среди этих цветов могло
Ответы (1)