Задать вопрос
17 июля, 07:17

Сформировать одномерный массив В из минимальных элементов строк двухмерного массива А (N, M) Паскаль, написать эту программу в тетрадь

+4
Ответы (1)
  1. 17 июля, 08:00
    0
    Const

    nm = 20;

    nn = 20;

    var

    a: array[1 ... nm, 1 ... nn] of integer;

    b: array[1 ... nm] of integer;

    i, j, m, n, mina: integer;

    begin

    Write ('Введите число строк и столбцов массива: ') ; Readln (m, n) ;

    Randomize;

    Writeln ('Исходный массив') ;

    for i : = 1 to m do

    begin

    for j : = 1 to n do

    begin

    a[i, j] : = Random (101) - 50;

    Write (a[i, j]:4)

    end;

    Writeln

    end;

    for i:=1 to m do

    begin

    mina:=32767;

    for j:=1 to n do if mina>a[i, j] then mina:=a[i, j];

    b[i]:=mina

    end;

    Writeln ('Сформированный массив') ;

    for i:=1 to m do Write (b[i]:4) ;

    Writeln

    end.

    Тестовое решение:

    Введите число строк и столбцов массива: 6 5

    Исходный массив

    46 - 32 - 6 20 36

    -2 - 41 - 10 - 42 26

    -33 16 - 25 9 46

    -36 20 - 50 36 - 37

    -41 16 34 - 8 9

    38 - 36 - 14 - 18 - 33

    Сформированный массив

    -32 - 42 - 33 - 50 - 41 - 36
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать одномерный массив В из минимальных элементов строк двухмерного массива А (N, M) Паскаль, написать эту программу в тетрадь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Дан одномерный массив. Из элементов массива равных 100, сформировать массив b., а из элементов меньших 33, сформировать массив с.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)