Задать вопрос
10 июля, 18:13

Помогите решить задачу в Паскале: вводится строка с клавиатуры. определить сколько в ней о.

+3
Ответы (2)
  1. 10 июля, 19:12
    0
    В условии задачи нечетко указано, какой символ искать: "о" - это может быть и латинская буква, и кириллическая. В программе предполагается, что это латинский символ, в противном случае его достаточно заменить в const на нужный.

    const

    c:char='o';

    var

    s:string;

    i, k:integer;

    begin

    Write ('Введите строку: ') ; Readln (s) ;

    k:=0;

    for i:=1 to Length (s) do if s[i]=c then Inc (k) ;

    Writeln ('Символ "', c,'" встречается ', k,' раз (а) ')

    end.

    Тестовое решение:

    Введите строку: Learn wisdom by the follies of others

    Символ "o" встречается 4 раз (а)
  2. 10 июля, 21:10
    0
    Var

    s:string;

    k, i:integer; {k-количество символов 'o', i-счетчик цикла}

    begin

    readln (s) ;

    k:=0;

    for i:=1 to length (s) do {цикл от 1 до длины строки}

    if s[i]='o'

    then k:=k+1;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу в Паскале: вводится строка с клавиатуры. определить сколько в ней о. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
С клавиатуры вводится строка. С новой строки вводится буква. Составьте программу подсчета количества заданных букв в заданной строке. Определить, является ли длина введенного слова числом, кратным трем.
Ответы (1)