Задать вопрос
8 октября, 19:25

С клавиатуры вводится строка символов. Составить программу, которая находит номер первого и последнего символа 'к' и заменяет все символы между этими буквами на звездочку.

Сделать алгоритм и программу

+2
Ответы (1)
  1. 8 октября, 20:41
    0
    program zwezda;

    uses Crt;

    var S: string;

    i, Len: integer;

    begin

    ClrScr;

    Write ('Ввод строки: ') ; ReadLn (S) ;

    ClrScr;

    WriteLn ('‘Строка: ', S) ;

    WriteLn;

    WriteLn ('Первый символ: ', S[1]) ;

    Writeln;

    Len:=length (S) ;

    WriteLn ('Посдедний символ: ', S[Len]) ;

    WriteLn;

    for i:=2 to len - 1 do

    S[i]:='*';

    WriteLn ('Результат: ', s) ;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится строка символов. Составить программу, которая находит номер первого и последнего символа 'к' и заменяет все символы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)