Задать вопрос
23 февраля, 22:03

Даны натуральное число n, целые числа a1, a2, a3 ..., an. найти количество и суммы тех членов данной последовательности, которые делятся на 5 и не делятся на 7

Прошу написать программу в Паскале

+1
Ответы (1)
  1. 24 февраля, 00:59
    0
    Const

    nn=100; { максимальное значение n }

    var

    i, n, k, s:integer;

    a:array[1 ... nn] of integer;

    begin

    Write ('Укажите натуральное число n: ') ; Read (n) ;

    Randomize;

    k:=0; s:=0;

    Writeln ('Сформированная последовательность') ;

    for i:=1 to n do begin

    a[i]:=Random (99) + 1; { случайное число на интервале [1; 99] }

    Write (a[i]:3) ;

    if (a[i] mod 5=0) and (a[i] mod 7 0) then

    begin Inc (k) ; s:=s+a[i] end;

    end;

    Writeln;

    Writeln ('Количество чисел, кратных пяти: ', k) ;

    Writeln ('их сумма равна ', s)

    end.

    Тестовое решение:

    Укажите натуральное число n: 39

    Сформированная последовательность

    15 83 69 64 56 50 13 70 55 40 22 82 45 67 31 36 16 52 67 44 63 23 52 62 89 33 40 32 17 14 98 15 5 58 46 68 57 72 90

    Количество чисел, кратных пяти: 9

    их сумма равна 355
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральное число n, целые числа a1, a2, a3 ..., an. найти количество и суммы тех членов данной последовательности, которые делятся на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны натуральное число n и последовательность целых чисел а1, а2, ..., аn ... Определить количество тех членов последовательности, которые нечетны. Найти сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Программу оформить в паскале) Даны натуральное число n и целые числа. Выяснить, верно ли, что количество тех чисел, которые меньше 20, равно пяти.
Ответы (1)
Дано натуральное n и последовательность чисел x1, x2, ..., xn. Вычислить среднее арифметическое членов последовательности. В первой строке содержится целое число n (1≤n≤100) - количество членов последовательности.
Ответы (1)
1. Дана последовательность из N (2
Ответы (1)