Задать вопрос
3 июля, 18:02

Дана последовательность целых положительных чисел. Найти произведение только тех чисел, которые больше заданного числа М. Если таких нет, то выдать сообщение об этом.

Нужно решить в Паскале с помощью линейных массивов

+2
Ответы (1)
  1. 3 июля, 21:36
    0
    Program p;

    uses crt;

    const N = 10; {N - количество чисел в последовательности}

    var i, p, M:integer; a:array[1 ... N] of integer;

    begin

    p:=1;

    write ('введите число M=') ; readln (M) ;

    writeln ('введите исходный массив') ;

    for i:=1 to N do {начало цикла по кол эл }

    begin

    write ('a[', i,']=') ; readln (a[i]) ; {ввод эл массива}

    if a[i]>M then p:=p*a[i];

    end;

    if M=1 then writeln (' элементов > M нет')

    else writeln ('p=', p) ; {печать произведения}

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность целых положительных чисел. Найти произведение только тех чисел, которые больше заданного числа М. Если таких нет, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из 10 элементов. Найти произведение только тех чисел, которые больше заданного числа М, вводимого с клавиатуры. Если таких нет, то выдать сообщение об этом.
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
Помогите с кодом по паскалю.→Нужно чтобы ответ который показывается было написано первый столбец столько положительных чисел а если нет положительных чисел в столбце то писало нет положительных чисел в этом столбце←Столбцы пронумеровать Изначально
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Найти среднее арифметическое всех положительных целых чисел от a до b (b>=a) Если таких чисел нет то вывести сообщение "Таких чисел нет" Программа на Паскале (net или abc)
Ответы (1)