Задать вопрос
30 марта, 23:12

Найти среднее арифметическое всех положительных целых чисел от a до b (b>=a) Если таких чисел нет то вывести сообщение "Таких чисел нет"

Программа на Паскале (net или abc)

+5
Ответы (1)
  1. 31 марта, 02:18
    0
    Program Task;

    Const a = 5;

    b = 10;

    Var i, c, d: Integer;

    Begin

    If a > b Then

    WriteLn ('Ошибка')

    Else

    Begin

    For i : = a To b Do

    If i > 0 Then

    Begin

    c : = c + i;

    d : = d + 1;

    End;

    If d > 0 Then

    WriteLn ('Результат: ', (c / d) : 5:2)

    Else

    WriteLn ('Таких чисел нет') ;

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти среднее арифметическое всех положительных целых чисел от a до b (b>=a) Если таких чисел нет то вывести сообщение "Таких чисел нет" ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
20.2 (№ 987) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит "NO").
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)