Задать вопрос
11 ноября, 13:48

1. Составьте программу вывода матрицы:

1 1 1 1

2 2 2 2

3 3 3 3

2. Составьте программу вывода матрицы:

1 2 3 4

1 2 3 4

1 2 3 4

+2
Ответы (2)
  1. 11 ноября, 15:28
    0
    {Задача 1}

    type Mat = arrsay [1 ... 3, 1 ... 4] of integer;

    var i: integer;

    A: Mas;

    begin

    for i:=1 to 3 do

    begin

    for j:=1 to 4 do

    Write (i:4) ;

    WriteLn;

    end;

    ReadLn;

    end.

    {Задача 2}

    type Mat = arrsay [1 ... 3, 1 ... 4] of integer;

    var i:integer;

    A: Mas;

    begin

    for i:=1 to 3 do

    begin

    for j:=1 to 4 do

    Write (j:4) ;

    WriteLn;

    end;

    ReadLn;

    end.
  2. 11 ноября, 16:49
    0
    Var

    i, j:integer;

    begin

    for i:=1 to 3 do

    begin for j:=1 to 4 do Write (i:2) ; Writeln end

    end.

    Результат выполнения программы:

    1 1 1 1

    2 2 2 2

    3 3 3 3

    var

    i, j:integer;

    begin

    for i:=1 to 3 do

    begin for j:=1 to 4 do Write (j:2) ; Writeln end

    end.

    Результат выполнения программы:

    1 2 3 4

    1 2 3 4

    1 2 3 4

    Программы отличаются ровно одним символом - именем переменной в обращении к процедуре вывода: Write (i:2) ; и Write (j:2) ;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составьте программу вывода матрицы: 1 1 1 1 2 2 2 2 3 3 3 3 2. Составьте программу вывода матрицы: 1 2 3 4 1 2 3 4 1 2 3 4 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
В заданной матрице A (n*n) найти минимум всех сумм абсолютных величин элементов матрицы по столбцам. Использовать процедуры ввода и вывода элементов матрицы по строкам.
Ответы (1)
Составить и отладить программу обработки матрицы размерности n*n. Выполнить программу для n=4. Подсчитать сумму элементов матрицы стоящих над главной диагональю в Pascal
Ответы (1)