Задать вопрос
28 октября, 02:16

Помогите решить задачи на дом:

1) Найти сумму элементов массива, больших данного числа b (b вводится с клавиатуры)

2) Есть ли в данном массиве элементы равные заданному числу? Если есть, то вывести номер одного из них.

+5
Ответы (1)
  1. 28 октября, 05:19
    0
    Const

    n = 15;

    var

    x: array[1 ... n] of integer;

    i, b, s: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    for i : = 1 to n do

    begin

    x[i] : = Random (50) ;

    Write (x[i]:3) ;

    end;

    Writeln;

    Write ('Введите значение b - > ') ; Readln (b) ;

    s:=0;

    for i : = 1 to n do if x[i]>b then s:=s+b;

    Writeln ('Сумма элементов, больших ', b,', равна ', s)

    end.

    Тестовое решение:

    Элементы массива

    8 46 29 23 21 14 14 8 20 26 15 49 44 35 33

    Введите значение b - > 30

    Сумма элементов, больших 30, равна 150

    const

    n = 15;

    var

    x: array[1 ... n] of integer;

    i, b: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    for i : = 1 to n do

    begin

    x[i] : = Random (50) ;

    Write (x[i]:3) ;

    end;

    Writeln;

    Write ('Введите значение b - > ') ; Readln (b) ;

    i:=1;

    while (x[i]b) and (i
    if x[i]=b then Writeln ('x[', i,']=', b)

    else Writeln ('Нет элементов со значением, равным ', b)

    end.

    Тестовое решение:

    Элементы массива

    24 6 28 46 25 9 12 47 34 0 20 47 15 10 34

    Введите значение b - > 20

    x[11]=20
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи на дом: 1) Найти сумму элементов массива, больших данного числа b (b вводится с клавиатуры) 2) Есть ли в данном ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер первого его вхождения. Формат входных данных С клавиатуры вводится натуральное число n (n≤100).
Ответы (1)
Всё сделать в программе PascalABC Задача №1 С клавиатуры вводится число n. Заполнить n элементов массива числами 2,4,8,16 ... и вывести массив. В массиве может находить не более 100 элементов. Задача №2 С клавиатуры вводится число n.
Ответы (1)